Override4414

joined 1 year ago
[–] Override4414@lemmy.world 2 points 8 months ago (4 children)

Is this post off-topic?

[–] Override4414@lemmy.world 1 points 8 months ago

that explains it in general, thanks.

As for why would a company do this - to prevent fraud and abuse. If a customer signs up and uses a stolen credit card, who do you think is on the hook for that loss? Not the victim, not the bank - us.

I really thought the victim is the one on the hook for that loss, since the money cannot be send back

[–] Override4414@lemmy.world 1 points 8 months ago (2 children)

I’ll reiterate that Stripe did not arbitrarily force that on you, Racknerd did.

Why would any company put this on their customer if they have an option? Does it mean government and policy force the company to use stripe to verify their customers?

[–] Override4414@lemmy.world 1 points 8 months ago (6 children)

this no shitpost?

 

I bought a 1-year VPS. The charge showed up on my credit card account, which means it was a successful transaction. Two days later, after the payment, Racknerd sent me a KYC verification link through Stripe. The next day, Racknerd suspended my VPS.

Why take my money, charge for a year of service, and then send me a link to verify myself?

The biggest issue here is with Stripe asking me to verify my identity, even though I'm not using their service. Yes, they might be legal, but their intrusive behavior in collecting people's information is unreasonable and should not be tolerated.

Racknerd is not innocent here. If you're having trouble accepting my payment, then send it back and don't provide me service. Why provide service for 2 days and then suspend my VPS? And then give me a cancellation button that only cancels the service but will not provide a refund?

This is what they said:

"We've received your cancellation request for this service, and it is in queue for the system to automatically process shortly. As a reminder, per our Terms of Service, refunds for any unused service time are not offered."

In the future, I recommend avoiding services that require Stripe for payment verification. Though it seems impossible to distinguish between the transactions that requires it and those don't.

Update: Racknerd have explained to me that cancellation of the VPS and a refund are separate processes, and a full refund will be issued.

 

I hosted searxng on portainer and receive PermissionError and no python application found error

Log:

PermissionError: [Errno 13] Permission denied: '/etc/searxng/settings.yml'

unable to load app 0 (mountpoint='') (callable not found or import error)

*** no app loaded. going in full dynamic mode ***

***
no python application found, check your startup logs for errors
***

[pid: 19|app: -1|req: -1/1] 127.0.0.1 () {28 vars in 330 bytes} [Sat May 17 05:06:00 2025] HEAD /healthz => generated 21 bytes in 0 msecs (HTTP/1.1 500) 3 headers in 102 bytes (0 switches on core 0)

I tried removing cap_drop (as instructed on https://github.com/searxng/searxng-docker/issues/115) but no luck

version: "3.7"

services:
  # caddy:
  #   container_name: caddy
  #   image: docker.io/library/caddy:2-alpine
  #   network_mode: host
  #   restart: unless-stopped
  #   volumes:
  #     - ./Caddyfile:/etc/caddy/Caddyfile:ro
  #     - caddy-data:/data:rw
  #     - caddy-config:/config:rw
  #   environment:
  #     # - SEARXNG_HOSTNAME=${SEARXNG_HOSTNAME:-http://localhost/}
  #     - SEARXNG_TLS=${LETSENCRYPT_EMAIL:-internal}
  #   cap_drop:
  #     - ALL
  #   cap_add:
  #     - NET_BIND_SERVICE
  #   logging:
  #     driver: "json-file"
  #     options:
  #       max-size: "1m"
  #       max-file: "1"

  redis:
    container_name: redis
    image: docker.io/valkey/valkey:8-alpine
    command: valkey-server --save 30 1 --loglevel warning
    restart: unless-stopped
    networks:
      - searxng
    volumes:
      - valkey-data2:/data
    # cap_drop:
    #   - ALL
    cap_add:
      - SETGID
      - SETUID
      - DAC_OVERRIDE
    logging:
      driver: "json-file"
      options:
        max-size: "1m"
        max-file: "1"

  searxng:
    container_name: searxng
    image: docker.io/searxng/searxng:latest
    restart: unless-stopped
    networks:
      - searxng
    ports:
      # - "127.0.0.1:8080:8080"
      - "20054:8080"
    volumes:
      - ./searxng:/etc/searxng:rw
    environment:
      # - SEARXNG_BASE_URL=https://${SEARXNG_HOSTNAME:-localhost}/
      - SEARXNG_BASE_URL="http://mydomain:20054/"
      - UWSGI_WORKERS=${SEARXNG_UWSGI_WORKERS:-4}
      - UWSGI_THREADS=${SEARXNG_UWSGI_THREADS:-4}
    # cap_drop:
    #   - ALL
    cap_add:
      - CHOWN
      - SETGID
      - SETUID
    logging:
      driver: "json-file"
      options:
        max-size: "1m"
        max-file: "1"

networks:
  searxng:

volumes:
  # caddy-data:
  # caddy-config:
  valkey-data2:

thx a lot!

 

I have tried a few times Creating an reddit account with VPN on but always get shadowbanned. Is there anything I can do to protect my privacy from reddit?

Or is there any public reddit account shared online that could be used publicly?

 

Are there any open-source Reddit frontends available for Windows? I’ve seen some options for Linux and Android, but so far I haven’t had any luck finding one that works on Windows.